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TRADEMARKS 
mPrep, ASP-1000, Grid-Tite, Standard Filter Coupler, Extreme Filter Coupler, and mPrep/Bench are 
trademarks of Microscopy Innovations. 

All other brands, product names, company names, trademarks and service marks are the properties of 
their respective owners. 

 
RESTRICTIONS AND LIABILITIES 
This document is provided “as is” and Microscopy Innovations assumes no responsibility for 
typographical, technical, or other inaccuracies in this document. Microscopy Innovations reserves the 
right to periodically change information that is contained in this document; however, Microscopy 
Innovations makes no such commitment to provide any such changes, updates, enhancements, or 
other additions to this document to you in a timely manner or at all. 

Other than the limited warranty contained in this user guide, Microscopy Innovations makes no 
representations, warranties, conditions or covenants, either express or implied (including without 
limitation, any express or implied warranties or conditions of fitness for a particular purpose, non- 
infringement, merchantability, durability, title, or related to the performance or non-performance of any 
product referenced herein or performance of any services referenced herein). 

This document might contain references to third-party sources of information, hardware or software, 
products or services and/or third-party web sites (collectively the “Third-party Information”). Microscopy 
Innovations does not control, and is not responsible for, any Third-party Information, including, without 
limitation the content, accuracy, copyright compliance, compatibility, performance, trustworthiness, 
legality, decency, links, or any other aspect of Third-party Information. The inclusion of Third-party 
Information in this document does not imply endorsement by Microscopy Innovations of the Third-party 
Information or the third party in any way. 

Microscopy Innovations does not in any way guarantee or represent that you will obtain satisfactory 
results from using the ASP-1000 as described herein. You assume all risk in connection with your use 
of the ASP-1000 or other mPrep products. 

Microscopy Innovations is not responsible nor will be liable in any way for your use of any of software 
or equipment that is not supplied by Microscopy Innovations in connection with your use of the mPrep 
ASP-1000 or other mPrep products. 

 
ORIGIN 
The mPrep ASP-1000 is manufactured in the United States of America. 

 
COPYRIGHT 
© 2020 Microscopy Innovations, LLC. All Rights Reserved. 

 
EDITIONS 
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CHAPTER 1. 
Getting Started 

 
Welcome to the mPrep™ASP-1000™, your automated biological specimen processor for 
electron microscopy applications. In addition to freeing lab technicians to work on other 
projects, the ASP-1000 

• enables one-touch specimen handling that maintains biological specimen integrity. 

• decreases specimen processing time. 

• provides walk-away automation. 

• decreases the amount of technician exposure time to toxic chemicals. 

• ensures consistency and quality in processing. 
 
 

ASP-1000 Component Identification & Specifications 
 
 
 
 
 
 

Fume Enclosure 
Exhaust Port 

 
Z -arm 

 
Pump Module, Syringes 

(power switch - 
back, upper right) 

HEPA Filter Port 
 
 

Laptop Controller 
running ASP-1000 Software 

 
Base Unit 
(power switch - 
back, upper right) 

 
Status Indicator 

8-channel Head 

Exhaust Fan 

Deck, 6 Plate Positions 

Thermal Control Unit 
(optional, below plates 
3 & 4) 
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mPrep ASP-1000 Specifications 
 Approx. dimensions with fume enclosure (W x D x H): 

48.3 cm x 61 cm x 63.5 cm (19" x 24" x 25") 

Base Unit 
Weight: 34 kg (75 lbs.) 
6 ANSI/SLAS format microplate-style reservoir capacity 

 Integrated fume enclosure 
 8-channel pipettor-style head 
 

Pump Module 
Dimensions (W x D x H): 20.3 cm x 20.3 cm x 30.5 cm 
(8" x 8" x 12") 

 Weight: 7.25 kg (16 lbs.) 

Exhaust Fan 
Dimensions (W x D x H): 20.3 cm x 25.4 cm x 20.3 cm 
(8” X 10” x 8”) 

 Dimensions (W x D x H): 25.4 cm x 35.6 cm x 2.54 cm 
(10" x 14" x 1”) 

Laptop Controller Weight: 1.6 kg (3.5 lbs.) 
 Windows 10, solid-state drive 
 ASP-1000 controller software 

Power Requirements 100-240 VAC, 47-63 Hz 
Net Weight 43.1 kg (95 lbs.) 

 
Equipment, Labware, & Consumables 

The base model of the ASP-1000 includes: 

• Base unit (fluid handling platform, 8-channel head assembly, deck platform assembly, 
and fume enclosure) 

• Pump module 

• Exhaust fan 

• Laptop controller with ASP-1000 controller software 

At the time of this writing, one add-on component is available to increase the flexibility and 
control of the ASP-1000. 

 

Optional Equipment Components Unit Cat. No. 

Thermal Control Unit (TCU) 1 90001 



ASP-1000 User’s Guide  7 

 
 
 
 

The instructions in this guide refer to mPrep capsules, filter couplers and reagent reservoir 
plates. This labware is required for operation of the ASP-1000. You can find these items 
and other common accessories in the table below. For the most up-to-date product list, 
see www.microscopyinnovations.com. 

 

Filter Couplers Unit Cat. No. 

mPrep/f30 Standard Filter Couplers™, 16/pk Pk 31500 

Capsules for Specimen Processing   

mPrep/s™ Capsule Pack 
8 capsules, 12 screens, 8 blank label sets, in storage box 

Pk 22200 

mPrep/s Capsules - 96-count 
96 capsules, screens & blank label sets 

Bag 22500 

Capsules for Grid Processing   

mPrep/g™ Capsule Pack 
16 capsules, with blank label sets, in storage box 

Pk 21300 

mPrep/g Capsules - 96-count 
96 capsules, screens & blank label sets 

Bag 21500 

Reagent Reservoir Plates Unit Cat. No. 

12-channel Reagent Reservoir Plate, polypropylene, single-pack Ea 52501 

12-channel Reagent Reservoir Plates, polypropylene, 5/sleeve Slv 52503 

12-channel Reagent Reservoir Plates, polypropylene, 25/case Cs 52502 

96-well Square-well Plates, 1.2ml, polypropylene,10/sleeve Slv 51010 

96-well Square-well Plates, 1.2ml, polypropylene,100/case Cs 51011 

96-well Plates, 500uL, polypropylene, 10/sleeve Slv 51001 

Plate Seals   

X-Pierce Cross-cut Vinyl Sheets, self-adhesive, pierceable, 100/box Box 53010 

Pierce Heat Seals*, foil heat sealing sheets, pierceable, 100/pk Pk 53070 

Accessories   

mPrep/Bench™ 96-well Silicone Rack Ea 34000 

mPrep/s Insertion Tool Ea 32010 

mPrep/s Workstation Ea 42100 

* For applying Pierce Heat Seal sheets, we recommend the 4titude 4s3™ Semi- 
Automatic Sheet Heat Sealer. 

http://www.microscopyinnovations.com/
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Equipment Placement & Installation 
• The ASP-1000 is designed with an integrated fume enclosure for venting vapors 

safely. Place the ASP-1000 in a location where the venting apparatus can be 
attached to a fume removal system to duct vapors outside. 

• If you decide to locate the ASP-1000 within a fume hood, it is acceptable to have an 
ASP-1000 field service engineer remove the ASP’s fume enclosure. 

• Position the ASP-1000 on a level surface indoors. 

• Ensure grounded 110V power supply and power switches are accessible. 

• Allow 10 cm (~4”) space on each side of the ASP-1000 for air flow. 

• If your lab is susceptible to power disruptions, use an uninterruptible power supply 
(UPS) to plug in all devices associated with the ASP-1000. 

• The ASP-1000 controller software will require minimal access to your institution’s 
public wi-fi network to log on as a guest and install the most recent version. 

 
ASP-1000 Software 

The ASP-1000 software installs files in the following locations: 
 

Component Location * 
ASP-1000 Software C:\Program Files\ASP-1000 
Protocols C:\Users\LAPTOP_NAME\ASP-1000\ASP-1000 Protocol Files 
Macros C:\Users\LAPTOP_NAME\ASP-1000\ASP-1000 Protocol Files 
Operators C:\Users\LAPTOP_NAME\ASP-1000\ASP-1000 Operators.txt 
Tray Files C:\Users\LAPTOP_NAME\ASP-1000\ASP-1000 Tray Files 
Protocol Releases C:\Users\LAPTOP_NAME\ASP-1000\ASP-1000 Releases 
Preferences C:\Users\LAPTOP_NAME\ASP-1000\ASP-1000 Preferences.txt 
Log Files C:\Users\LAPTOP_NAME\ASP-1000\ASP-1000 Log Files 

* LAPTOP_NAME is defined during installation by the ASP-1000 field service engineer. 

Note: The ASP-1000 software will not allow you to save files elsewhere. 
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ASP-1000 Workflow 
In general, the broad categories of tasks below represent the workflow to incorporate the 
ASP-1000 into a lab’s EM biological specimen preparation process. However, depending 
on the particular application (for example TEM, immunolabeling, or 3DEM) and your lab’s 
best practices, the workflow may vary. 

Start the ASP-1000 and Select Your Protocol 

Power on the ASP-1000. For more information, see Starting the ASP- 
1000 in Chapter 2. 

Log in to the laptop controller, and select and review the protocol you 
want to run. For more information, see Selecting a Protocol in Chapter 2. 

 
 

Load Your Reagents 

Load the correct reagents into the appropriate microplate or reservoir 
position per the tray map in the selected protocol. For more information, 
see Loading Reagents in Chapter 2. 

Place the reagent plates onto the ASP-1000 deck, sliding them into the 
correct positions. 

 
 

Load Your Specimen Capsules 

Load your specimen into the mPrep capsule appropriate for your 
application. For more information, see Appendix C. 

Store loaded capsules short-term in the mPrep/Bench™ 96-well silicone 
rack. Once you begin running a protocol, the software will prompt you to 
mount the capsules on the 8-channel head. 

 
 

Run the ASP-1000 

Click the Run button in the ASP-1000 software on the laptop controller. 
For more information, see Running a Protocol in Chapter 2. 
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Protocol Information and Safety 
• Read the ASP-1000 User’s Guide before use. 

• Use eye protection at all times. 

• Wear gloves and take standard precautions as you handle samples. 

• Observe chemical safety requirements when using this instrument 

• To ensure that the exhaust fan is working, check that the telltale flag hanging from the 
exhaust port is pulled in the direction of the airflow. 

• Do not use aluminum plate sheets with osmium, as a reaction will occur. 

• Do not use adhesive plate seals with acetone or ethanol, as these chemicals will 
dissolve the adhesive. 

• Dispose of used reagents per your institution’s safety protocols. 
 
 

Online Help 
The ASP-1000 software has built-in hover tips for real-time help. Place the cursor over 
any item within the software window to display a help box describing its function. 

 
Technical Support 

Microscopy Innovations technical support scientists have the necessary laboratory and 
analytical experience to respond to your inquiries. 

Telephone (715) 384-3292 
Monday - Friday, 9:00am to 5:00pm US Central Time 

Email info@microscopyinnovations.com 

mailto:info@microscopyinnovations.com
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CHAPTER 2. 
Basic Instructions: Operator 

 
This chapter describes how to use the mPrep ASP-1000 system to prepare samples for 
electron microscopy applications. The ASP-1000 has two modes: developer and operator. 
Developer mode is reserved for your on-site ASP developer and is covered in Chapter 4. 
One person is delegated as developer. For day-to-day running of established protocols on 
the ASP-1000, you will use operator mode. Multiple users can be set up as operators. 

The ASP-1000 is designed to be another pair of hands in your lab. Once trained, lab 
personnel will find the ASP-1000 straightforward to use to ensure consistent processing 
and eliminate technician-to-technician variability. 

 
Starting the ASP-1000 

Note: Information on the location of power switches can be found in ASP-1000 
Component Identification & Specifications in Chapter 1. 

 To start the ASP: 

1. Flip the power switch on the ASP-1000 base unit to the ON position. The Z-arm will 
home itself (0, 0, 0), if necessary, and the instrument status indicator light will 
illuminate blue. 

2. Flip the power switch on the pump assembly to the ON position. 

3. Flip the power switch on any optional ASP-1000 components to the ON position. 

4. On the laptop controller, press the power button to start the computer. 

5. Start the ASP-1000 software by clicking the program icon , located on the desktop 
and/or in the taskbar of the laptop controller. The ASP-1000 Dashboard window 
displays. 
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6. Click the Operator button, select your name from the drop-down list, and click the OK 
button. The ASP-1000 Operator window opens, displaying your name in the upper left 
corner on the Select Operator drop-down list. 

 
Getting to Know the ASP-1000 Operator Window 

 
Software Status Indicator Progress Indicators 

 

Operator Menus 
Select Operator 

Action Commands 
 
 
 
 
 

Protocol Listing 
Tray Map 

 
 
 
 
 
 
 

Operator Menus 
Allow you to select your protocol, print a tray map, and operate or send manual 
commands to the ASP-1000. 

Select Operator 
Displays a drop-down list of all operators authorized to use the ASP-1000.Your on- 
site ASP developer has set up authorized operators previously within developer 
mode. 
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Action Commands 
Run: Starts the ASP-1000 at the currently selected step within the Protocol Listing 
panel. 

Pause: Pauses the ASP-1000 at the conclusion of the currently selected protocol 
step. If the current step includes repeats, the ASP-1000 will complete all before 
pausing and displaying the window: 

Note: The software status indicator light retains the color associated with Run mode 
(by default, green). To continue running the protocol from the currently selected step, 
click the OK button. To stop immediately, click Stop, but do so after an aspiration step 
to ensure the specimen does not dry out. 

Stop: Stops the ASP-1000 immediately, regardless of where it is within a step, and 
returns to the beginning of the protocol. 

Software Status Indicator 
Displays a configurable light indicating the current status of the software. Under 
default programming conventions: 
Red = Manual intervention needed 
Green = Running 
Blue = Standby 

Progress Indicators 
End of Step: Estimates the time in seconds that the current step will finish. 

End of Protocol: Estimates the time in seconds that the entire protocol will finish. 

Tray Map 
Displays the 6 reagent plates on the ASP-1000’s deck and each one’s contents for 
the selected protocol. 

Protocol Listing 
Displays each step within the protocol. 

Tip: If a step is visually truncated on the right side, hover the cursor over it to display 
the entire step. 
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Selecting a Protocol 
The ASP-1000 software requires your on-site ASP developer to release a protocol to a 
specified operator before s/he can select it from the protocol list. Depending on an 
operator’s training and experience, a developer may allow access only to select protocols. 
If a protocol is not available in your operator list, see your on-site ASP developer. 

 To select a protocol: 

1. In the ASP-1000 Operator window, check the Operator Name in the upper left corner 
to ensure you are using the correct operator account. If not, click within the field to 
display a drop-down list and select the correct name. 

2. From the File menu, select Open. The Open Protocol window displays. 

3. Click the Pick a File from the List drop-down list and select the protocol you want to 
run. 

 
4. Click OK. The Tray Map panel displays the reagent layout, and the Protocol Listing 

panel displays each step within the selected protocol. 

 
Loading Reagents 

After you have selected a protocol in the ASP-1000 Operator window, the software 
displays the tray map, which indicates the reagents required per plate to perform the 
protocol and their location on the ASP-1000’s deck. The ASP-1000 allows up to six SBS- 
format reservoir plates on its deck. Plate columns and rows are numbered as follows: 

96 Round-well Plate 96 Square-well Plate 



ASP-1000 User’s Guide  15 

 
 
 
 

 
12-Column Reservoir Plate 

 

Note: When placing a reagent tray on the deck, 1A is always in the upper left. 

 To load reagents: 

1. Navigate to the ASP-1000 Operator window, and check the Operator Name in the 
upper left to ensure you are using the correct operator account. If not, click within the 
field to display a drop-down list and select the correct name. 

2. Select the protocol of interest. For more information, see Selecting a Protocol earlier 
in this chapter. The protocol loads, display the tray map and protocol listing 

3. Review the tray map. Choose from the following: 

• View the tray map online on a mobile device to load the trays (i.e., no printing). 

a. From the File menu, select Send Screenshot. The Send the Screenshot? 
window displays. 

 
b. Verify the email address of the operator, and click Yes. The system sends a 

screenshot of the tray map within the Operator window via email to the 
operator. 

The operator can open the email on a mobile device to view the tray map. 
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• Print the tray map. 

a. From the File menu, select Print. 

Your default internet browser window will load two tabs: one listing each step 
in the protocol, and another displaying the tray map. 

b. Print from your internet browser window, or save as a PDF to a USB drive 
and print elsewhere. 

Note: Alternatively, you can use the layout provided in Appendix B. 
96-well Reagent Plate Template to hand write the reagents per column. 

4. Locate or make the required reagents. 

 Warning: Use appropriate precautions when handling all reagents. 

5. Using an alcohol-resistant marker or label maker, label the front of each plate with the 
required reagents prior to dispensing. 

6. Dispense the required volumes of reagents into the plates, per the tray map. 

Note: We recommend sealing pre-filled 96 square-well (51011) and 12-column 
reservoir plates (52502) with Pierce Seal aluminum heat seals (catalog no. 53070) 
and 96 round-well plates (used for IEM; 51001) with X-Pierce adhesive vinyl plate 
seals (53010). 
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7. Slide the prefilled plates onto the deck of the ASP-1000, under the clips that hold 
each plate, into the correct positions per the tray map. For example, slide plate 1 into 
the upper left position (i.e., closest to the back panel of the base unit, left side) and 
plate 2 in the upper right position. Refer to the placement guide below: 

 
8. Double-check that the reagent reservoir positions on the deck match the ones on the 

tray map. 

 
Loading Specimens in Capsules 

Note: The fixation method used to preserve biological specimens prior to EM specimen 
preparation is a key factor in the quality of the resulting EM images. We recommend 
Karnovsky’s Fixative. 

mPrep capsules are required for preparing specimens on the ASP-1000 and help prevent 
loss, misidentification, and damage. Two types of mPrep capsules are available, and 
which one you use depends on your application: 

mPrep/s (Specimen) Capsules 

Securely hold biological specimens up to 3 mm3 for TEM, SEM, and 3DEM specimen 
preparation and other applications. Capsules hold specimens through fixation, en bloc 
staining, dehydration, infiltration, embedding, and sectioning. 

mPrep/g (Grid) Capsules 

Hold grids for TEM grid staining, on-grid immunolabeling, or negative staining of 
macromolecules (DNA, RNA, protein). 

 To load specimens into the mPrep/s or mPrep/g capsules, see Appendix C: 
Loading mPrep Capsules. 

Plate 1 
Plate 2 

Plate 3 
Plate 4 

Plate 5 
Plate 6 
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Running a Protocol 
The ASP-1000 integrates seamlessly into your existing workflow. When the instrument is 
installed at your site, the ASP-1000 field service engineer will work with your on-site ASP 
developer to write or optimize protocols to align with your lab’s practices (see Creating or 
Modifying Protocols in Chapter 4.) 

We encourage users to share ASP protocols. For more information, see Sharing Protocols 
Between Labs in Chapter 4. 

 To run a protocol on the ASP-1000: 

1. Make sure you have followed the actions described earlier in this chapter: 

a. See Starting the ASP-1000 in this chapter. 

b. See Selecting a Protocol in this chapter. 

c. See Loading Specimens in this chapter. 

d. See Loading Reagents in this chapter. 

2. On the laptop controller, make sure the first step is selected in the Protocol Listing 
panel and click the Run button. 

The ASP-1000 will perform its homing routine, prepare to run the protocol, and 
prompt you to mount mPrep capsules preloaded with specimens. 

3. Mount 1 to 8 capsules preloaded with specimens on the 8-channel head. To do so, 
push the open end of an mPrep capsule up onto a channel head and rotate counter- 
clockwise slightly until it fits securely. 

Note the locations of A – H when mounting your capsules. Location A on the 8- 
channel head is closest to the back of the ASP-1000 unit, and location H is closest to 
the front. 

 
 
 
 
 
 
 
 
 

Location A 
 

Location H 
 

Note: You can run the ASP-1000 with fewer than 8 capsules. 
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4. Click OK. 

The ASP-1000 will run the selected protocol, prompting for user input or action as 
required. 

Upon completion of the protocol, the software will prompt you to click OK to raise the 
Z-arm to make room to remove the capsules. 

5. Click OK. The software will prompt you to remove the capsules. 
 

6. Use your thumbnail to apply a gentle downward force on the lip of each capsule to pry 
it from the channel head, so it will fall into the mPrep/Bench silicone rack. 

 
7. When all the capsules are removed, click OK. The ASP-1000 will finish running the 

protocol and return to the beginning, and the Z-arm will return to the home (0, 0, 0) 
position. 

8. Remove the silicone rack from the ASP’s deck. 

9. For polymerization, choose one of the following: 

• If specific specimen orientation is required, polymerize per your existing SOP, for 
example in a flat mold or BEEM® capsule. 

• If polymerizing directly in the mPrep/s capsule, add resin to top off each capsule. 

10. Place the flat mold or silicone rack in an oven at a temperature and time appropriate 
for your resin (e.g., 60°C for Embed 812). 
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Monitoring When a Protocol or Step Will Complete 
 To monitor when a protocol or step will complete: 

On the laptop controller, open the ASP Operator window running a protocol. 

The progress indicators specify the time the current step will complete as well as when the 
entire protocol will finish. 

 
Pausing or Stopping the ASP-1000 

You may need to pause or stop the ASP-1000 mid-protocol. For example, perhaps you 
forgot to fill a reagent plate or placed one in the wrong location on the ASP-1000 deck. 
The ASP-1000 allows users to pause the equipment temporarily and then restart it at its 
current location within a protocol. Or you may want to stop the ASP-1000 from running the 
remainder of the protocol altogether. 

The ASP-1000 provides manual controls that enable you to correct an error mid-protocol, 
including moving the Z-arm and 8-channel head out of the way to better access the ASP’s 
deck. 

Note: You can use the manual controls only when the ASP-1000 is stopped. These 
controls are not available if the ASP-1000 is paused. 
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 To pause the ASP-1000 and correct an error on its deck, choose from the following: 

• If the Z-arm is not obstructing your access to reagent plates on the ASP-1000 deck: 

1. Click the Pause button. 

The ASP-1000 finishes the current step before pausing; for example, if a step 
has 500 repeats, the ASP-1000 will perform all 500 actions prior to pausing. The 
Z-arm will raise but stay in its current x and y planes, and the software will 
display a Pause window requesting action to continue to the next step. 

 
 

2. Make adjustments on the ASP-1000 deck as necessary. 

3. When ready, click the OK button to continue running the protocol from the point 
where it left off. 

• If the Z-arm is obstructing your access to reagent plates on the ASP-1000 deck: 

1. Wait for an aspiration step to complete, to ensure the specimen does not dry out, 
then click the Stop button. The ASP-1000 immediately stops, and the Z-arm 
returns to the home (0, 0, 0) position. 
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2. Use the manual controls located in the Actions menu to correct the error: 

Zero Z 
Moves the Z-arm to the 0 (top) z coordinate. 

Home Stage 
Moves the Z-arm to the home position (back left, or 0, 0, 0). 

Return Z 
Returns the Z-arm and the 8-channel head to its position within the protocol 
step where you stopped the program. You will select this command prior to 
continuing on with the protocol. 

Aspirate 
Draws in the amount of reagent you indicate in the Amount slider. 

Dispense 
Expels the amount of reagent you indicate in the Amount slider. 

Switch to Input 
Moves the 8 pump valves to ambient air. 

Switch to Output 
Moves the 8 pump valves into position to aspirate or dispense from the 8- 
channel head. 

3. After fixing the error, select Return Z from the Actions menu. This command 
brings the Z-arm back to the location where the ASP-1000 was stopped initially. 

4. Click the Run button. The ASP-1000 will continue running from the protocol step 
where it had stopped. 
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 To stop the ASP-1000: 

Click the Stop button. The ASP-1000 stops running immediately, regardless of the step or 
number of repeats, and returns to the beginning of the protocol. The Z-arm returns to the 
home (0, 0, 0) position. 

Note: You may want to wait for an aspiration step to complete before stopping the ASP- 
1000 to ensure the specimens do not dry out. 

 
Cleaning Up and Shutting Down 

The ASP-1000 offers fast and easy clean-up following specimen preparation. 

 To clean up the ASP-1000: 

1. Dispose of leftover reagents and plates on the ASP’s deck per your lab’s standard 
SOP. 

 Warning: Use the appropriate precautions when handling all reagents. 

2. After all plates are removed, wipe down the ASP-1000’s deck using a damp cloth. 

3. Turn off the ASP-1000 base unit, pump assembly, exhaust fan, and any optional 
components (see ASP-1000 Component Identification & Specifications in Chapter 1). 

4. On the laptop controller, select Quit from the File menu. 

The ASP-1000 software application closes. 

5. Shut down your laptop using on-screen prompts. 

Note: The power button, screensaver, and sleep functions have been disabled to 
prevent inadvertent power down of the ASP-1000. 
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CHAPTER 3. 
Global Preferences & Settings 

 
You can configure several mPrep ASP-1000 settings as preferences, which are then 
applied when running any protocol. These preferences, configured within developer mode, 
set up default settings and include: 

• Authorized operators trained to use the ASP-1000 

• Access to specific protocols 

• Aspirate/dispense parameters 

• Developer connectivity credentials 

• Default z reagent tray settings, which configure the z coordinate (depth) of reagent 
12-column plates, 96 round-well plates, and 96 square-well plates. 

• Thermal Control Unit (TCU) communication port settings 

• Default tray file 

Note: Some of these preferences, such as the z coordinate and aspirate and dispense 
settings, can be individually adjusted when writing or editing a protocol. 

 
Adding or Removing an Operator 

Because it takes skill and training to do quality sample preparation for electron 
microscopy, the ASP-1000 provides control over who can use the instrument. Your on-site 
ASP developer can add and remove ASP operators. The ASP-1000 provides further 
control by enabling the on-site ASP developer to specify which protocols have been 
released to an operator, ensuring the user has been appropriately trained before using the 
instrument. For more information, see Granting or Removing Access to a Protocol 
Program in this chapter). 

 To add a new operator to run protocols on the ASP: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in Chapter 4. 
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2. From the Edit menu, select Operators…. The ASP-1000 Operators Editor window 
displays. 

 
3. For each individual trained to operate the ASP-1000, complete the following fields: 

Operator Name 
Enter the name of the individual granted access to run the ASP-1000. 

SMS Number 
(optional) Enter the operator’s 10-digit cell phone number, using no spaces, 
symbols, or punctuation. (For example, 9876543210 is correct, but (987) 654- 
3210 is not.) The ASP-1000 will use this number to send alerts via text message, 
if programmed as a step within a protocol. To enable this feature, the laptop 
controller must be connected to your institution’s wi-fi. 

SMS Carrier 
Enter the service provider for the operator’s cell phone, for example AT&T, 
Sprint, etc. 

EMail 
Enter the operator’s email address. The ASP-1000 may use this address for 
alerts via email, if programmed as a step within a protocol. 

4. Click the Save button. The file is saved as 
C:\Users\ LAPTOP_NAME\ASP-1000\ASP-1000 Operators.txt. 
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Granting or Removing Access to a Protocol Program 
The ASP-1000 ensures data quality and reproducibility by eliminating variability among 
laboratory technicians. However, because technicians still require training to use the ASP- 
1000 with specific protocols, the software provides control over which protocols are made 
available to each operator. 

 To grant or remove access to a protocol program: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in Chapter 4. 

2. From the Edit menu, select Releases…. The ASP-1000 Operator Release Editor 
window opens. 

 
 

Predefined users are listed as column headings. If you do not see a particular 
operator listed, see Adding or Removing an Operator in this chapter. 

Predefined protocols are listed as rows. If you do not see a particular protocol listed, 
make sure all protocols are saved to the directory C:\Users\LAPTOP_NAME\ASP- 
1000\ASP-1000 Protocol Files and have a *.txt extension. 

3. Click the corresponding cell of each protocol to select or deselect it as being available 
to a predefined operator. Selected cells will highlight in green. 

4. Click the Save button to save and exit the window. 
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Setting Global Z Coordinates 
The ASP-1000 field service engineer defines the x and y coordinates for your ASP during 
installation, which become fixed parameters you will not need to adjust under normal 
circumstances. However, you may need to modify the z coordinate (depth), which is plate 
specific. The z coordinate is measured in millimeters (mm), with 0 being at the top and 
106 as the max depth. 

 To set global z coordinates: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in Chapter 4. 

2. From the Edit menu, select Tray Files…. The Tray File Editor window opens, 
displaying the currently loaded (default) tray file, the location for loading and unloading 
capsules, as well as the default x, y, and z coordinates for plates 1 through 6. 

 
 

Note: Do not modify the x or y coordinates. These values have been set and tested 
by the ASP-1000 field service engineer upon installation. 

3. Edit the z coordinate values per your plate and reagent. The z dimension runs 
vertically, up from and down toward the deck of the ASP-1000 and range from 0 (top) 
to 106 (bottom). Typical depths are: 

12-column plate: 106 
96 square-well plate: 100 
96 round-well plate: Reagent level dependent 

4. Choose one of the following and follow the on-screen prompts: 

• Click the Save button to save your changes to the current filename. 

• Click the Save As button to save the file under a new name. 

The file with your updated z coordinates is saved in the following directory: C:\Users\ 
LAPTOP_NAME\ASP-1000\ASP-1000 Tray Files. 
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Setting Default Aspirate and Dispense Preferences 
A common, frequently used step in any ASP-1000 protocol is the “Move – Aspirate – 
Dispense” (MAD) command. You can set default aspiration and dispense values, as well 
as the hold time. 

Note: A developer can override these default settings in a particular protocol within the 
Edit tab. For more information, see Creating or Modifying Protocols in this chapter. 

 To set default aspirate and dispense preferences: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in Chapter 4. 

2. From the Edit menu, select Settings…. The ASP-1000 Settings Editor window opens. 

3. Modify the pump parameters as necessary: 

Speed 
Sets the pump speed. Values range from 0 to 40, where 40 is the slowest. The 
default value is 12. 

Volume (ul) 
Sets the default volume of reagent to be aspirated or dispensed. 

Asp. Hold (sec) 
Sets the default hold time, in seconds, after aspiration. 

Disp. Hold (sec) 
Sets the default hold time, in seconds, after dispensing. 

Repeats 
Sets the default number of times the reagent is aspirated and dispensed during 
that step. 

4. Click the Save button to save your changes. The Save Settings window displays. 
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5. Click OK to confirm and close the Save Settings window. 

Your preferences are saved in C:\Users\ LAPTOP_NAME\ASP-1000\ASP-1000 
Preferences.txt. 

6. Click Cancel to exit the ASP-1000 Settings Editor. 
 
 

Setting Up the Thermal Control Unit (TCU) 
The Thermal Control Unit (TCU) is a separately purchased add-on to the ASP-1000. The 
TCU, attached via USB to the base unit, provides two Peltier equipped stations for heating 
and cooling the reagent reservoirs in positions 3 and 4 on the ASP-1000’s deck. The ASP- 
1000 field service engineer typically sets up the TCU upon installation. 

 To set up the TCU: 

1. Plug the USB from the TCU in plate position 3 into the base station. Note the specific 
port you use. 

2. Repeat step 1 for the TCU in plate position 4. 

3. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in Chapter 4. 

4. From the Edit menu, select Settings…. The ASP-1000 Settings Editor window opens. 

5. Click the drop-down menus for TCU 1 (plate position 3) and TCU 2 (plate position 4) 
and select the correct communication port address for each. 

6. Click the Save button to save and exit the ASP-1000 Settings Editor window. 
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Viewing Developer Account Preferences 
The ASP-1000 can send text messages to an operator, for example to monitor the system 
for tracking purposes or at points in a protocol where manual intervention may be 
required. To do so, during installation the field service engineer will set up a specific ASP- 
1000 administrative email account and password. The ASP-1000 uses this email account 
to send SMS messages to an operator’s phone, if programmed as a step within a protocol. 
To enable this feature, the laptop controller must be connected to your institution’s wi-fi. 

 To view developer account preferences: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in Chapter 4. 

2. From the Edit menu, select Settings…. The ASP-1000 Settings Editor window opens, 
displaying the email account name. The password remains hidden to prevent 
inadvertently changing it. 

 
 Warning: Do not modify this account information or password, and do not log into 

another Gmail account on the ASP laptop controller. If you do, the ASP-1000 text 
messaging capability will not work. 

 
Selecting a Default Tray File for Use with Protocols 

Different protocols may require different reagent plates, for example 12-column plates 
versus 96-well plates, or a combination of the two. If so, the z coordinate will change 
according to the depth of the reservoir per the different plates. To control the Z-arm and 
then save your changes as a tray file to use at a different time, see Setting Global Z 
Coordinates in this chapter. 

The default tray file is specified within developer mode. The ASP-1000 uses the default 
tray file with all protocols until you select a different tray file within the developer’s ASP- 
1000 Settings Editor window. 
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 To select the default tray file: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in Chapter 4. 

2. From the Edit menu, select Settings…. The ASP-1000 Settings Editor window opens. 

3. Click within the Tray File Name field. The Open window displays. 

4. Click the Pick a File from the List drop-down menu, select a file, and click the OK 
button. 

 

5. Click the Save button to save and exit the ASP-1000 Settings Editor window. 
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CHAPTER 4. 
Advanced Operation: Developer 

 
The mPrep ASP-1000 gives labs total control over their automated methods used to 
prepare samples for electron microscopy. At installation, the ASP-1000 field service 
engineer will help you implement your lab’s protocols on the ASP. The ASP provides the 
flexibility to easily modify protocols as necessary to conform to best practices in your lab 
or to program your own protocols from scratch. In either scenario, the ASP-1000 frees lab 
technicians to work on other projects while it performs repetitive yet critical steps for 
quality EM sample preparation. 

One individual at a site is designated as the on-site ASP developer. The on-site ASP 
developer has advanced ASP privileges, and this chapter describes how to use this mode 
to create new or modify existing protocols, define the operators who can use the ASP, and 
designate which protocols an operator has access to run. 

 
Accessing Developer Controls 

 To access ASP-1000 developer controls: 

1. Start the ASP-1000 software by clicking the program icon , located on the desktop 
and/or in the taskbar at the bottom of the laptop controller. The ASP-1000 Dashboard 
window opens. 

 
2. Click the Developer button. The ASP-1000 Developer window opens. 
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Getting to Know the ASP-1000 Developer Window 
The ASP-1000 developer window enables you to set ASP-1000 global parameters and 
provides a developer sandbox for creating, editing, and testing protocols before releasing 
them to designated operators for use in your lab. 

 
 

Action Commands 

Developer Tabs 

 
Progress Indicators 

 
 
 
 

Developer Sandbox 
 
 
 
 
 
 
 

DEVELOPER TABS 

You will find three tabs that enable you to perform developer actions: 

• Edit: Use this tab to write new and edit existing protocol methods within the sandbox. 

• Scratchpad: Use this tab to program or test a single step in isolation. For example, 
you may want to test a particular step prior to adding it to an existing protocol. 

• Run: Use this tab to verify the reagent tray setup on the ASP-1000 deck. As the 
software cycles through each protocol step, it highlights the reagent column in use. 
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DEVELOPER SANDBOX 

The developer sandbox commands and parameters are available in both the Edit and 
Scratchpad tabs. These commands enable you to create and modify protocols. For more 
information on specific commands, see Appendix D. Protocol Commands & Parameter 
Settings. 

 
 

Protocol Commands    
    Protocol Listing 

 
 
 

Command Parameters 
 
 
 

Current Protocol Path 

 
Protocol Commands 

Command: Displays a drop-down list of available commands for controlling the ASP- 
1000. For a description of each command, see Appendix D. Protocol Commands & 
Parameter Settings. 

Comment: Attaches an optional comment to display with the current step. The Step 
Comment is most useful for the Move-Asp-Disp command to list the reagent being 
used on the tray map. 

Command Parameters 
Only those parameters specific to the selected Command are made available for 
modification. Those parameters not applicable appear grayed out. 

Current Protocol Path 
Displays the path and filename of the current protocol loaded in the Developer 
window. 

Protocol Listing 
Displays each step within the protocol. 

 
 

Creating or Modifying Protocols 
During the installation of your ASP-1000, the ASP-1000 field service engineer will work 
with you to either write new protocols to match your existing SOP or to modify any 
protocols the company provides to correspond to your lab’s best practices and 
procedures. This section details how to use the developer sandbox within the Edit and 
Scratchpad tabs to create or modify a protocol. 

Note: It is often easier to modify an existing protocol than to start completely from scratch 
to program a new protocol. See Tips for Creating a New Protocol in this chapter. 
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 To create a new protocol: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in this chapter. 

The Developer window displays with the Edit developer tab open. With no protocol 
loaded, the Command Parameters appear grayed out and the Protocol Listing panel 
is empty. 

2. From the File menu, select New. The Protocol Listing panel displays the step 0) No- 
Operation. 

By default, the system names all new protocols new-protocol.txt. To prevent 
overwriting prior protocol files, always rename the file. 

3. From the File menu, select Save As…. The Save As window displays. 

4. Type a new filename in the Choose a File Name text box and click OK. 

Note: By default, the software allows you to save the file only in 
C:\Users\LAPTOP_NAME\ASP-1000\ASP-1000 Protocol Files. 

5. With No-Operation selected in the Protocol Listing panel, click the Command drop- 
down list, select a command, and specify its parameters. For more information, see 
Appendix D. Protocol Commands & Parameter Settings. 
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6. Repeat step 5 to build the steps of the protocol. 

Note: To create a macro for a series of steps that may be repeated within a single 
protocol or between protocols, see Creating and Using Macros in this chapter. 

7. (Optional) To test a single step, a macro, or an entire protocol, see Testing Steps, 
Macros, and Protocols in this chapter. 

8. Select Save from the File menu to save the protocol. 

 To modify an existing protocol: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in this chapter. 

The Developer window displays with the Edit developer tab open. With no protocol 
loaded, the Command Parameters appear grayed out and the Protocol Listing panel 
is empty. 

2. From the File menu, select Open. The Open Protocol window displays. 

3. Click the Pick a Protocol from the List drop-down list, select the file of interest, and 
click OK. 

Note: By default, the ASP-1000 recognizes only those protocols saved in C:\Users\ 
LAPTOP_NAME\ASP-1000\ASP-1000 Protocol Files with a *.txt extension. 
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The selected protocol loads in the Edit tab of the developer sand box, displaying the 
path and filename in the Current Protocol Path field at the bottom of the window. The 
steps of the protocol display in the Protocol Listing panel. 

 
4. Choose from the following: 

• To insert a new step: 

a. Select the step within the Protocol Listing panel after which you want to 
insert a new step. 

b. From the Edit menu, select Insert New. The software inserts a No-Operation 
step below the selected step. 

c. With the new step selected, click the Command drop-down list, select a new 
ASP command, and edit its parameters as necessary. For more information, 
see Appendix D. Protocol Commands & Parameter Settings. 

• To copy and paste a step: 

a. Select the step within the Protocol Listing panel that you want to copy. 

b. From the Edit menu, select Copy. 

c. Select the step within the Protocol Listing panel after which you want to 
insert the copied step. 

d. From the Edit menu, select Paste. The step is inserted into the Protocol 
Listing panel below the selected step. 

• To modify a step: 

a. Select the step within the Protocol Listing panel that you want to modify. 

b. Click the Command drop-down list and select a new command. 

c. Adjust the new command’s parameters as necessary. 
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• To delete a step: 

a. Select the step you want to delete within the Protocol Listing panel. 

b. From the Edit menu, select Cut. The step is deleted from its current location. 

5. Save the protocol file. 

• From the File menu, select Save to save the protocol under the existing filename. 

• From the File menu, select Save As… to save the protocol under a new filename, 
and follow the system prompts to do so. 

Note: By default, the software allows you to save protocol files only in C:\Users\ 
LAPTOP_NAME\ASP-1000\ASP-1000 Protocol Files. 

 
TIPS FOR CREATING A NEW PROTOCOL 

• Start all protocols by homing the stage and the pump. These commands place 
the Z-arm into the correct starting position and center the pistons in the syringes. 
For example: 

0) LED Color – Green 
1) Home Stage 
2) Home Pump 

• Use the Pump Valve Input and Pump Valve Output parameter settings to move 
the plungers into the correct positions (syringe volume is 1 ml, thus aspirate 500 
µl to position the piston in the middle of the syringe). The piston should be in the 
center of the syringe. For example: 

3) Valve In 
4) Aspirate speed 0 vol 500 µl hold 0.00 s 
5) Valve Out 

 
 
 
 
 

• For the ASP-1000 to alert you to load and unload the mPrep capsules, you must 
program those steps within the protocol. For example: 

6) Load/Unload X 0.000 mm Y 255.000 mm Z 9.000 mm 
7) LED Color – Red 
8) Dialog Popup: Attach mPrep Capsules to pipettor shaft and press ‘Enter’. 
9) LED color – Green 

• For each Move-Asp-Disp step in the protocol, type the reagent name or its use in 
the Comment text box. This text will appear in the tray map, which can be 
accessed in the Run tab within the Developer window or via the Operator 
window. 
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Viewing a Protocol 
The ASP-1000 makes it easy to view and read through a protocol in its entirety, as the 
steps are written as you see them in the Protocol Listing panel. To view a protocol, display 
it in a web browser window. 

 To view a protocol: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in this chapter. 

The Developer window displays with the Edit developer tab open. 

2. From the File menu, select Open. The Open Protocol window displays. 

3. Click the Pick a File from the List drop-down list, select the file of interest, and click 
OK. 

Note: By default, the ASP-1000 recognizes only those protocols saved in 
C:\Users\LAPTOP_NAME\ASP-1000\ASP-1000 Protocol Files with a *.txt extension. 

The selected protocol loads in the Edit tab of the developer sandbox, displaying the 
path and filename in the Current Protocol Path field at the bottom of the window. The 
steps of the protocol display in the Protocol Listing panel. 
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4. From the File menu, select Print. Your default internet browser window opens, 
displaying the protocol in a new tab for easy viewing and printing. 

 
 
 

Creating and Using Macros 
You may find there are multi-step, repeated commands within a protocol or between 
protocols. Instead of adding each command as a separate step, you can save them 
together as a macro, which you then can insert within a protocol as a single step. Macros 
are like mini-protocols and can aid in creating consistency both within and across lengthier 
protocols. 

 To create a macro, follow the steps in Creating or Modifying Protocols in this 
chapter. 

You create and save macros just as you do a regular protocol. To avoid confusion, you 
may want to devise a file naming convention to separate macros from full protocols, as 
they are saved in the same directory. For example, you may want to include “macro” in the 
filename, i.e. Startup_Macro.txt. 

Note: By default, the software allows you to save macro files only in C:\Users\ 
LAPTOP_NAME\ASP-1000\ASP-1000 Protocol Files. 

 To use a macro file within a protocol: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in this chapter. 

The Developer window displays with the Edit developer tab open. 
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2. From the File menu, select Open. The Open Protocol window displays. 

3. Click the Pick a File from the List drop-down list, select the file of interest, and click 
OK. 

Note: By default, the ASP-1000 recognizes only those protocols saved in 
C:\Users\LAPTOP_NAME\ASP-1000\ASP-1000 Protocol Files with a *.txt extension. 

The selected protocol loads in the Edit tab of the developer sandbox, displaying the 
path and filename in the Current Protocol Path field at the bottom of the window. The 
steps of the protocol display in the Protocol Listing panel. 

4. Click on the step after which you want to insert a macro and select Insert New from 
the Edit menu. The command No-Operation is inserted beneath the current step in 
the Protocol Listing panel. 

5. With the No-Operation command selected, choose Select Macro File from the 
Command drop-down list. The Open Protocol window displays. 
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6. Click the Select a Protocol from the List drop-down list, select the macro file of 
interest, and click the OK button. The macro filename appears as a single step within 
the Protocol Listing panel. 

Note: The software will display all files with a *.txt extension located in the 
C:\Users\LAPTOP_NAME\ASP-1000\ASP-1000 Protocol Files directory, which will 
include previously saved macro files as well as full protocol files. If you do not select a 
filename, the software automatically creates a file called Startup.txt, which contains 
no content, to use within that step of the protocol. 

 
Configuring Notices of Required Operator Input 

While the ASP-1000 is automated, there may be points within a protocol where manual 
intervention is needed. The ASP-1000 can notify an operator in four ways. 

• Status indicator light on the ASP-1000. By default, the color is blue. 

• Sound. The laptop controller will sound an audible alert. 

• Software popup alert. The ASP-1000 software will pause and display a window 
notifying the operator of the type of input required. 

• Text message. The ASP-1000 can send a text message to any operator’s cell phone 
with a notification of the required operator input. To enable this feature, the laptop 
controller must be connected to your institution’s wi-fi. 

 To configure notices of required operator input: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in this chapter. 

The Developer window displays with the Edit developer tab open. 

2. From the File menu, select Open. The Open Protocol window displays, listing all 
available protocol files. 

 

3. Click the Select a Protocol from the List drop-down list, select the file of interest, and 
click OK. The selected protocol loads in the Protocol Listing panel. 

4. Click on the step after which you want to insert a notice of required user input and 
select Insert New from the Edit menu. The No-Operation command is inserted 
beneath the current step in the Protocol Listing panel. 
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5. Select the No-Operation step and choose from the following: 

• Instrument Status Indicator light 

a. Select the LED Color command in the Command drop-down list. The LED 
Color parameter displays the default color green (R: 100, G: 255, B: 0). 

b. Click the LED Color field. A color picker window displays. 

c. Place the cursor in any of the three color bars. As you move the cursor, the 
rectangle in the lower left corner of the window displays the color at the 
cursor point. 

Note: The specific RGB values of the color at the cursor point display at the 
bottom of the color picker window. 

d. To select a color, choose from the following: 

Note: Some colors work better on the LED than others. Be sure to observe 
how they look to your eye on the LED indicator light and do not rely on the 
color on your laptop screen. 

• Click within one of the three color bars. The window closes and the 
selected color displays as the LED Color parameter. 

• Select a color used previously by clicking a swatch under History. The 
window closes and the color selected displays as the LED Color 
parameter. 
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• To select a specific color palette, RGB (red, green, blue), or HSL (hue, 
saturation, luminosity) color: 

i. Click the painter’s palette button  in the lower right corner of 
the color picker window. The Color window displays. 

 

ii. Choose from the following: 

• Select an existing swatch under Basic Colors. 

• Click and move the cursor within the rainbow canvas square to 
find a specific color. 

• Type the specific RBG or HSL values of your choice. 

The large Color|Solid swatch displays the color selected. 

iii. (Optional) Click the Add to Custom Colors button to add the color to 
the Custom Color swatches. 

iv. Click the OK button. The Color window closes and the selected 
color is displayed as the LED Color parameter. 

• Sound. Select Play Sound from the Command drop-down list. 

Note: You can adjust the volume using F2 and F3 on the laptop controller. 

• Software Popup Alert 

a. Select Dialog Popup from the Command drop-down list. 

b. Type the message you want to display in the Dialog Text parameter text 
box. 
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• Text Message 

a. Select Send SMS from the Command Drop-down list. The SMS Picker 
window displays. 

 

b. Click Pick an Operator from the List to display a drop-down list and 
select an operator. For more information on entering default operator 
information, see Adding or Removing an Operator in Chapter 3. 

c. Click the OK button. The selected operator and his/her information 
automatically displays in the Operator, SMS Number, and SMS Carrier 
parameter text boxes. 

d. Type a message in the Dialog Text parameter text box to be sent to the 
operator’s phone. 

e. From the File menu, select Save to save your changes to the protocol. 
 
 

Testing Steps, Macros, and Protocols 
As you create new protocols and macros or edit existing ones, you may want to test the 
procedures to ensure they work as intended. Your testing may include: 

• an individual protocol step or macro 

• a portion of or an entire protocol, ignoring repeats 

• the layout of reagents on the ASP-1000 deck 

 To test an individual protocol step: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in this chapter. 

The Developer window displays with the Edit developer tab open. 

2. From the File menu, select Open. The Open window displays, listing all available 
protocol files. 

3. Select the protocol of interest and click the OK button. The selected protocol loads in 
the Edit tab of the developer sandbox. 

4. Select the step you want to test within the Protocol Listing panel. 
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5. From the Edit menu, select Copy. 

6. Select the Scratchpad tab. 

7. From the Edit menu, select Paste. The copied command and its parameters are 
pasted into the Scratchpad Step panel. 

8. Click the Run button to test the step and observe the ASP-1000. 

9. (Optional) Modify the parameters as necessary. For more information, see Appendix 
D. Protocol Commands & Parameter Settings. 

10. Repeat steps 8 and 9 until you are satisfied with the performance. 

11. From the Edit menu, select Copy. 

12. Select the Edit tab to return to the full set of steps within the Protocol Listing panel. 

13. Select the step within the Protocol Listing panel after which you want to insert the new 
step. 

14. From the Edit menu, select Paste. The copied step displays within the Protocol Listing 
panel beneath the currently selected step. 

15. Delete the step you replaced. To do so, select the step and from the Edit menu, 
select Cut. 

 To test a protocol and the layout of reagents on the ASP-1000 deck: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in this chapter. 

The Developer window displays with the Edit tab open in the developer sandbox. 

2. From the File menu, select Open. The Open window displays, listing all available 
protocol files. 

3. Select the protocol of interest and click the OK button. The selected protocol loads in 
the Protocol Listing panel of the Edit tab. 

4. Select the step with which you want to start the testing. 
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5. (Optional) From the Operate menu, select Test Mode. The Override Repeats window 
displays. This mode enables you to decrease the number of aspirate-dispense repeat 
commands, which take the most time when running a protocol, to a number you 
specify. 

 
 

6. Specify the number of repeat actions you want applied to every aspirate and dispense 
command in the Protocol Listing panel and click the OK button. 

7. Click the Run button. The software runs through the protocol, highlighting in green the 
column of the reagent plate used in the respective steps of the protocol. 

 
Sharing Protocols Between Labs 

The ASP-1000 enables researchers to easily share protocols between labs. A protocol file 
is simply a set of human-readable commands that the ASP-1000 uses to process 
samples. You can share protocols via email, save to and download them from a cloud 
location, or copy them to or from a physical storage device, such as a USB drive. 

 To share a protocol: 

1. From the ASP-1000 laptop controller’s desktop, navigate to the default protocol 
directory: C:\Users\ LAPTOP_NAME\ASP-1000\ASP-1000 Protocol Files 

Note: The ASP-1000 recognizes only those protocols saved in this location with a *.txt 
extension. 

2. Choose from the following: 

• If you are sharing a protocol, copy the file from the ASP-1000 Protocol Files 
directory to a location from which you can share it, for example a USB drive or 
cloud storage, and email it to a colleague. 

• If a protocol is being shared with you, copy the file to the ASP-1000 Protocol 
Files directory. 

The ASP-1000 will recognize and display the *.txt file the next time the Open file 
selection window displays. 

To view the full protocol, see Viewing a Protocol in this chapter. 

To modify the protocol, see Creating or Modifying Protocols in this chapter. 
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CHAPTER 5. 
Maintenance & Troubleshooting 

 
The mPrep ASP-1000 should be cleaned on a regular basis and follow a routine 
maintenance schedule as laid out in this chapter. 

 
Routine Maintenance 

The ASP-1000 instrument should be cleaned on a regular basis. Normal standards of 
laboratory safety and routine maintenance procedures are necessary to keep the ASP- 
1000 in good, serviceable condition. Inspect the ASP-1000 for obvious damage whenever 
you clean or use it. 

Always wipe up spills immediately. Take the necessary GLP safety precautions when you 
clean to protect yourself against the effects of chemicals. 

 

Area Item Frequency Action 
 

Deck After each 
processing run 

Clear the deck of all plates and gently 
wipe with a soft, damp cloth. Do not 
use solvents. 

 
 

Base Unit 

8- Channel Head After each 
processing run 

 
Fume Enclosure Monthly 

 
Approx. every 5 

Gently wipe with a soft, damp cloth. 
Do not use solvents. 

Use cleaner provided. Avoid cleaners 
containing ammonia, e.g., Windex®, 
which may damage the surface. 
Replace when visibly black from 

Filter Coupler runs, depending 
on use 

osmium or showing other signs of 
contamination. 

 
 

 

Pump 
Assembly 

High-grade FEP 
Tubing 

Monthly Visually inspect. If damage found, 
replace. 

 
 

 

Syringes Monthly Visually inspect. If damage found, 
replace. 

 
 

 
Deck Silicone Rack Quarterly 

Visually inspect. Discoloration is 
indicative the rack is becoming brittle. 
Replace. 

 
 
 
 

Laptop 

Monitor Monthly Gently wipe with a soft, damp 
microfiber cloth. Do not use solvents. 

 
 

Unplug and turn off the laptop. With 
the laptop open, turn it upside down 
and tap gently or shake to dislodge 

Controller 
Keyboard Monthly debris. Set down right side up and use 

a microfiber cloth lightly dampened 
with water to wipe keyboard. To 
further remove debris from between 
keys, use a can of compressed air. 
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Annual Maintenance 
To help keep your ASP-1000 in peak condition and running smoothly, we recommend 
scheduled maintenance at least once per year. Microscopy Innovations offers an 
extended service plan that is intended to help you avoid unnecessary downtime, reduce 
strain on your laboratory staff, and substantially extend the life of your ASP-1000. For 
more information, contact Microscopy Innovations. 

 
ASP-1000 Software Installation & Updates 

New versions of the ASP-1000 software are periodically released. Your on-site ASP 
developer will receive an email with instructions and a link to download and install any 
required software upgrades. 

 
Adjusting the Z Height of the 8-Channel Head 

When the ASP-1000 is initially installed at your site, the field service engineer will calibrate 
the Z-arm to align precisely with the x, y, and z coordinates of the six plate locations on 
the ASP-1000 deck. We recommend recalibrating the ASP-1000’s Z-arm under the 
following circumstances: 

• If you move the ASP-1000 to a different location 

• As part of an annual maintenance 

• If you use different types of reagent plates. For example, a 12-column plate, 96 
round-well plate, and 96 square-well plate will each have a different z parameter. 

 To calibrate the Z-arm: 

1. Navigate to the ASP-1000 Developer window. For more information, see Accessing 
Developer Controls in Chapter 4. 

2. From the File menu, select Open. The Open window displays, listing all available 
protocol files. 

3. Select the filename of a protocol for which you want to calibrate the Z-arm to a 
particular set of trays and click the OK button. The selected protocol opens in the 
Developer window, displaying each step in the Protocol Listing panel. 
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4. From the Edit menu, select Tray Files…. The ASP-1000 Tray File Editor window 
opens, displaying the position for loading and unloading capsules as well as the 
default x, y, and z coordinates for plates 1 through 6. 

 
5. Edit the default x, y, and z values as necessary. 

 
Z Dimension 

 
 
 
 
 
 
 

Y Dimension X Dimension 
 
 
 
 

The x dimension starts in the back left corner of the ASP-1000 deck and runs to the 
right. 

The y dimension starts in the back left corner of the ASP-1000 deck and run to the 
front edge of the deck. 

The z dimension starts at the top of the ASP-1000 and runs downward toward the 
deck. 
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6. Choose from the following: 

• Click the Save button to save your changes to the current filename. 

• Click the Save As button to save the file under a new name. Follow the on- 
screen prompts. 

The Tray File Editor window closes, returning you to the Edit tab in the Developer 
window. 

7. Select a step in the Protocol Listing panel at a point where you can observe the 
movement of the Z-arm and click the Run button. 

8. Repeat steps 4 through 7 as needed. 

9. Save your changes. Choose from the following: 

• Click the Save button to save your changes to the current filename. 

• Click the Save As button to save the file under a new name. Follow the on- 
screen prompts. 

The file with your updated x, y, and z coordinates is saved in the following directory: 
C:\Users\ LAPTOP_NAME\ASP-1000\ASP-1000 Tray Files 

 
Changing Filter Couplers 

Filter couplers protect the ASP-1000’s 8-channel head and the pump module from 
damaging fumes associated with some of the reagents, osmium tetroxide in particular. 

You need to change the filter couplers based on visual cues indicating contamination. 
Exposure to osmium makes filter coupler surfaces turn black; the more exposure, the 
sooner the color change. You should visually track the color of the filter coupler: when the 
bottom of the filter is black and the middle is brown, it is time to change the filter. 
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1. Move the Z-arm to the position for loading and 
unloading capsules. 

2. Flip the power switch of the ASP-1000 base 
unit to the OFF position. 

3. Gently, manually raise the Z-arm to the top 
position. 

4. Place an empty 96-well plate, in portrait 
orientation, under the “shelf” created by the Z- 
arm. 

5. Holding the 96-well plate in place with your 
right hand, use your left hand to push down 
on the white plastic block to de-compress the 
springs holding the U-bracket, which holds the 
filter couplers in place. 

6. Once the U-bracket clears the tip shafts, slide 
it to the left to remove it. 

7. Replace the filter couplers with new ones. 

8. Re-install the U-bracket by reversing the 
process. 

9. Remove the 96-well plate. 

10. With the fresh filter couplers mounted on the 
shafts, give each one a slight turn counter- 
clockwise to confirm a tight seal. 

 
Step 4 

 
 
 
 
 
 
 
 
 
 
 
 

Step 5 
 
 
 
 
 
 
 
 
 
 

Step 6 
 
 
 
 
 
 
 
 
 
 
 
 

Step 8 
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Troubleshooting 
 

LOG FILES 

Each time the ASP-1000 runs, it automatically creates a log file capturing the operator 
name, protocol name, time spent on each step, and amounts and names of reagent used. 
You can find log files stored in C:\Users\LAPTOP_NAME\ASP-1000\ASP-1000 Log Files. 
These files are human readable and designed to be accessible for other departments, 
such as HR or Accounting, to analyze and assign costs, monitor project progress, or 
maintain appropriate reagent inventory. 

 
ERROR MESSAGES 

 
Error Possible Cause Corrective Action 
Didn’t find the stage! 
Cycle the power, check 
connections, and try again. 

Robot power is off. 

USB-to-square-USB cable is not 
connected or has failed. 

Cycle power on ASP-1000. 

Check the connections on 
both ends of the USB-to- 
Square-USB cable. 

Try again. 

Replace cable if still not 
communicating. (Many 
printers use the same cable.) 

Error:005 Illegal Command May occur upon startup after 
reconnecting laptop controller. 

Press “Ok” and system will 
recover automatically. 

Error:016 Home movement 
required 

Movement stopped by blockage of 
an axis. Most likely cause is a 
stalled z-axis from entering the 
wrong z-depth. 

Cycle power to return head to 
the home position. Check 
method and decrease z- 
depth. For more information, 
see Setting Global Z 
Coordinates in Chapter 3. 

Error:018 Passthrough 
command pending 

Pump communication is lost. Cycle power on the pump. 

Check both ends of the cable 
with D-shaped 9-pin RS-232 
serial port connectors: one 
end connects to the “COM2” 
port on the back of the ASP- 
1000, and the other end 
connects with the connector 
on the back of the pump 
housing. 
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APPENDIX A. 
Microscopy Innovations Warranty 
mPrep™ ASP-1000™ Automated Specimen Processor 

 
Coverage & Term 

Microscopy Innovations, LLC (“MI”) warrants the mPrep ASP-1000 Automated Specimen 
Processor (“Equipment”) as supplied by Microscopy Innovations and its authorized distributors 
to be free from defects in materials and workmanship for one (1) year from the date of 
shipment by Microscopy Innovations to the end-user customer. The Equipment covered by 
this warranty includes: 

• BASE UNIT (fluid handling platform, 8-channel head assembly, deck platform 
assembly, and fume enclosure) 

• PUMP MODULE (8-channel syringe pump) 
 
 

Remedies & Service 
Microscopy Innovations shall, at its discretion, repair or replace Equipment found in its sole 
determination to be defective; provided Microscopy Innovations has been notified in writing 
of such defect within the warranty period. The repair or replacement of defective Equipment 
shall constitute buyer’s sole remedy and Microscopy Innovation’s sole obligation hereunder. 
Warranty service shall include: 

• Telephone support; 
• Parts and labor; 
• Travel costs for on-site repairs; 
• Shipping costs for return-to-factory/depot repairs. 

 
LIMITATIONS AND RESTRICTIONS 

The following limitations and restrictions apply to this warranty: 

1. The Warranty covers all parts manufactured or purchased by Microscopy Innovations 
and incorporated into the Equipment except the following: 

a. LAPTOP CONTROLLER (computer) provided by MI is covered only for a period 
of 30 days against defects in materials and workmanship; Windows operating 
system and any software other than ASP-1000-specific software is not warranted 
by MI. 

b. Exhaust Fan and additional accessories used for installation are not warranted. 

2. The Warranty covers all ASP-1000-specific software included in/with the Equipment and 
licensed by Microscopy Innovations for Equipment operation. The software shall 
perform according to the criteria set forth in the ASP-1000 User’s Guide. The software is 
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intended solely for use in the operation of the Equipment; the Warranty does not cover 
use of the software for functions other than those identified and described in the User’s 
Guide; use of the software with other software not licensed by Microscopy Innovations; 
and use of the software in equipment not supplied by Microscopy Innovations. 
Modification of the software voids the Warranty. 

3. The Warranty does not cover wear and tear resulting from normal laboratory use; 
including discoloration or deterioration of external frame, housing and other 
component finishes resulting from installation in damp or hot environments, exposure 
to chemical reagents or corrosive cleaners, and use of high-pressure washers. 

4. The Warranty does not cover the following items: 

a. User maintainable components and peripherals, as identified in the ASP-1000 
User’s Guide; 

b. Consumables and supplies; 

c. Accessory products not supplied with the Equipment as shipped and installed; 

d. Used or refurbished equipment not sold, inspected or approved by Microscopy 
Innovations 

5. The Warranty does not cover loss or damage, including loss and corruption of data 
resulting from: 

a. Modification of the Equipment not approved by Microscopy Innovations; 

b. Inadequate site preparation; 

c. Misuse, abuse, neglect, and inadequate maintenance of the Equipment; 

d. Repair of the Equipment by other than Microscopy Innovations or persons 
certified by Microscopy Innovations; 

e. Use of equipment for any other purpose than microscopy specimen preparation. 

6. The Warranty does not cover, and Microscopy Innovations is not responsible nor will it 
in any circumstances be liable in any way for any consequential, incidental, indirect and 
special damages arising out of or in connection with the Equipment and its use, 
including but not limited to injury and damage to persons or property, and loss of 
business revenue and profits. 

7. The Warranty is for the sole benefit of the original end user of the Equipment and is not 
transferrable. 

8. This Warranty is in lieu of and replaces and supersedes all other warranties, express 
or implied including, but not limited to warranties of merchantability and fitness for a 
particular purpose. 
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APPENDIX B. 
96- well Reagent Plate Template 
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Note: T o mai ntain p  oper 96-wel spaci ng, do not resize this image. 
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APPENDIX C. 
Loading mPrep Capsules 

 
 

mPrep/s Capsules 
 

UNORIENTED SPECIMENS 
 
 
 

1. Remove screen from 
mPrep/s capsule. 

 
 
 
 
 
 
 
 
 
 
 

2. Load specimen and 
replace screen. 

 
 
 
 
 
 
 
 
 
 
 

3. Label capsule and 
process the specimen on 
the ASP as directed. 

 
 
 
 
 
 

Attach to ASP-1000 
8-channel head 

and process 
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ORIENTED SPECIMENS 
 
 
 

1. Label capsule and process 
the specimen on the ASP 
as directed. 

 
 
 
 
 
 

2. Load and orient specimen. 
A. Compression Method 

 
 
 
 
 
 
 
 
 
 
 

B. Pinch Method 
 
 
 
 
 
 
 
 
 
 
 
 

3. Label capsule and process 
the specimen on the ASP 
as directed. 
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mPrep/g Capsules 
 
 
 
 

1. Use forceps to guide grids 
into the Grid-Tite™ slots. 

 
You can insert up to 2 
prepared grids into each 
capsule. 

 
 
 

2. Insert each grid to the 
point of resistance (a) 
plus ~1mm (b). 

 
Do NOT insert grid to the 
bottom of the slots. 

 
 
 
 
 
 

3. Label capsule and process 
the specimen on the ASP 
as directed. 
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APPENDIX D. 
Protocol Commands & Parameter Settings 

 
You access Commands, which define the steps in a protocol, in developer mode within both 
the Edit and Scratchpad tabs of the sandbox. While some steps for the ASP-1000 are defined 
within global settings (see Chapter 3. Global Preferences and Parameters), you can override 
these defaults with values defined here. 

Comment 
Inserts an operator comment for an individual step. 

Note: It is important to use the Comment text box with the “Move-Asp-Disp” 
Command to define reagent plate contents, which will appear on the tray map. 

No Operation 

Default placeholder for a step when you click the Insert Step button. 

Move-Asp-Disp (Move-Aspirate-Dispense) 
Overrides the default pump parameters specified in the Preferences Editor, which are 
auto populated here. (For more information, see Setting Default Aspirate and 
Dispense Preferences in Chapter 3.) 

Step Comment: Text entered in this text box appears on the tray map in the Edit tab. 
Type the reagent used in this step. 

Plate Number: Values range from plate 1 – 6. 

Row Number: Values range from row 1 – 8. 

Stage Z (mm): Specifies the depth of the 8-channel head. 

Speed: Values range from 0 to 40, with 40 being the slowest. 

Vol (ul): Amount of liquid, in microliters. 
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Asp. Hold (s): Length of time in seconds to hold after aspirating reagent into the 
capsule. 

Disp. Hold (s): Length of time in seconds to hold after dispensing reagent from the 
capsule. 

Repeats: Number of aspirate and dispense repeat actions. 

Home Stage 
Sets the Z-arm to the home position (0,0,0). 

Home Pump 
Moves pump to the home position. 

Select Plate/Row 
Moves the Z-arm to the specified location on the ASP-1000 deck. 

Plate Number: Values range from plate 1 – 6. 

Row Number: Values range from row 1 – 8. 

Stage Z (mm): Specifies the depth of the 8-channel head. 

Pump Aspirate 
Sets the length of time to hold prior to aspirating reagent from the capsules. 

Speed: Values range from 0 to 40, with 40 being the slowest. 

Vol (ul): Amount of liquid in microliters to aspirate. 

Asp. Hold (s): Sets the length of time in seconds to hold the liquid prior to aspirating. 

Pump Dispense 
Sets the length of time to hold prior to dispensing reagent from the capsules. 

Speed: Values range from 0 to 40, with 40 being the slowest. 

Vol (ul): Amount of liquid in microliters to dispense. 

Disp. Hold (s): Sets the length of time in seconds to hold the liquid prior to 
dispensing. 

Pump Speed 

Sets the pump speed, ranging from 0 to 40, with 40 being the slowest. Note that 
slower speeds of aspiration and dispensing are gentler on the specimen. As a 
benchmark, the fastest speed at 100ul is one second to dispense and one second to 
aspirate. 

Pump Valve Input 

Switches valve to input position to draw ambient air into the eight syringes in the 
pump assembly. 

Pump Valve Output 

Switches valve to output position, which connects the eight syringes in the pump 
assembly to the capsules. 
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Status Indicator on the ASP- 
1000 instrument (see ASP- 
1000 Components in Chapter 
1.) 

 
Instrument Status Indicator 
in the Operator’s software 
window (see Getting to Know 
the ASP-1000 Operator 
Window in Chapter 2.) 

 
Instrument Status Indicator 
in the Developer’s window (see 
Getting to Know the ASP-1000 
Developer Window in Chapter 
4.) 

 
 
 
 
 
 

For X, Y, and Z coordinates, 
see Setting Global X, Y, 
and Z Coordinates in 
Chapter 3.) 

Load/Unload 

Moves the Z-arm into default position to load capsules onto or unload capsules from 
the 8-channel head. The default position is defined as a global preference in the Tray 
Files Editor window. For more information, see Selecting a Default Tray File for Use 
with Protocols in Chapter 3. 

LED Color 
Sets the customizable LED color of the Status Indicator on the ASP-1000 instrument 
as well as the Instrument Status Indicator in the operator’s and developer’s software 
windows. 

LED Color – Red 

Sets the LED color of the Status Indicator on the ASP-1000 instrument as well as the 
Instrument Status Indicator in the operator’s and developer’s software windows as 
red. 

LED Color – Green 

Sets the LED color of the Status Indicator on the ASP-1000 instrument as well as the 
Instrument Status Indicator in the operator’s and developer’s software windows as 
green. 

LED Color – Blue 

Sets the LED color of the Status Indicator on the ASP-1000 instrument as well as the 
Instrument Status Indicator in the operator’s and developer’s software windows as 
blue. 

Move Abs X 
Sets the absolute position, in millimeters, of the x axis coordinate for the 8-channel 
head. 

Move Abs Y 

Sets the absolute position, in millimeters, of the y axis coordinate for the 8-channel 
head. 

Move Abs Z 

Sets the absolute position, in millimeters, of the z axis coordinate for the 8-channel 
head. 

Move Abs XY 

Sets the absolute position, in millimeters, of the x and y axis coordinates for the 8- 
channel head. 

Move Abs XYZ 

Sets the absolute position, in millimeters, of the x, y, and z axis coordinates for the 8- 
channel head. 



66 ASP-1000 User’s Guide 

 
 
 
 

Move Rel X 

Sets the position, in millimeters, of the x axis coordinate for the 8-channel head 
relative to its current position. 

Move Rel Y 

Sets the position, in millimeters, of the y axis coordinate for the 8-channel head 
relative to its current position. 

Move Rel Z 

Sets the position, in millimeters, of the z axis coordinate for the 8-channel head 
relative to its current position. 

Stage Pause 

Adds a short delay between steps. 

Stage Pause (s): Time, in seconds, paused between steps. 

Peristaltic Pump On 

Controls the peristaltic pump, turning it on. 

Peristaltic Pump Off 

Controls the peristaltic pump, turning it off. 

Play Sound 

Plays a sound to audibly notify the operator that user input is required. 

Dialog Popup 

Displays a window to visually notify the operator of the user input required. 

Dialog Text: Type a message in the text box to appear as a popup message on the 
laptop controller. 

Send SMS 

Sends a text message to notify the individual specified that user input is required. 

Operator Name: The name of the individual granted access to run the ASP-1000. 
The only operator names allowed are defined within Adding or Removing an Operator 
in Chapter 3 

Note: To enable this feature, the laptop controller must be connected to your 
institution’s wi-fi. 

Select Macro File 
Inserts a file containing a set of multiple protocol steps, enabling the developer to 
ensure consistency within and across protocols. 

Macro Filename: The name of the selected macro file. 
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TCU-1 Set 
Sets the temperature of the thermal control unit below plate 3 on the ASP-1000 deck. 

Temp (C): Type the temperature in Celsius. 

TCU-2 Set 
Sets the temperature of the thermal control unit below plate 4 on the ASP-1000 deck. 

Temp (C): Type the temperature in Celsius. 
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